AndroidでVPN(L2TP/IPSec) その2

かなり前にAndroidとCiscoルータ間でL2TP/IPSecが繋がらないネタを書いたわけですが、どうやらWindowsからは接続できるようです。

特に接続構成は変えておらず、またコンフィグの抜粋は以下のとおりです。
このコンフィグの場合、事前共有キーを”cisco”、ユーザ名とパスワードをそれぞれ”foo”、”bar”で接続できます。

#NATルータの内側にいるので、UDP 500,4500,1701はこのルータにフォワーディングしておく必要があります。

!
hostname Router
!
vpdn enable
vpdn multihop
!
vpdn-group 1
! Default L2TP VPDN group
 accept-dialin
  protocol l2tp
  virtual-template 1
 no l2tp tunnel authentication
!
username foo password 0 bar
!
crypto isakmp policy 1
 encr 3des
 authentication pre-share
 group 2
crypto isakmp key cisco address 0.0.0.0 0.0.0.0 no-xauth
crypto isakmp keepalive 30 periodic
!
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
 mode transport
!
crypto dynamic-map dynmap 1
 set nat demux
 set transform-set ESP-3DES-SHA
!
crypto map crymap 1 ipsec-isakmp dynamic dynmap
!
interface FastEthernet0
 ip address 192.168.0.2 255.255.255.0
 crypto map crymap
!
interface Virtual-Template1
 ip unnumbered FastEthernet0
 peer default ip address pool L2TP-POOL
 ppp authentication chap
!
ip local pool L2TP-POOL 192.168.0.250 192.168.0.251
!

Androidで接続できないのは、crypto ipsec transform-setの部分だと思うんですけど。どうなんだろ。

シェアする

フォローする